Exchange 2010 SP2 Update – IIS6 WMI requirement

Having recently completed a round of Exchange 2010 SP2 upgrades I haven’t really found any gotchas, assuming you read the documentation first.

One item I think could catch a few people out is the requirement for “IIS 6 WMI Compatibility” to be installed of CAS role servers. This can easily be installed as part of the upgrade using: /m:upgrade /installwindowscomponents

If you choose to run the GUI (setup.exe) you will need to install the IIS6 WMI Compatibility component of IIS or run the following PS:

Import-Module ServerManager
Add-WindowsFeature Web-WMI